win+apache+php5.3.x+fastcgi+zend guard loader

背景:
win7+apache2.4 vc9 + php5.3.20 nts vc9 + LoadModule fcgid_module modules/mod_fcgid.so +zend gurad loader3.3
note:php5.3与zend解密组合 只能是php nts 版的 5.3版本的php包里没有php5apache2_x.dll 即不能用apache2handler方式 所以选择fastcgi

配置:
在apache的httpd.conf最下面添加如下

不能启动的问题:

1 注意如果你以前指定了PHPIniDir的位置 一定要注释掉!!!!!
2 如果出现了诡异的html无法解析 那么很有可能是缺少
DefaultType text/plain
解释:
有时会发生这样的事:服务器会被要求提供一个文档,而这个文档的类型无法由它的MIME类型映射所决定。
服务器必须通知客户端其文档的内容类型。所以当一个未知类型出现时,将会使用DefaultType 。

或者你也可以用AddType text/html .html 来指定 这句话就是指将html后缀的文件当做text/html

附加zend:
在php.ini中附加
[Zend]
zend_extension=”E:/web/php5.3.20ts/extras/ZendLoader.dll”
zend_loader.enable=1
zend_loader.disable_licensing=0
zend_loader.obfuscation_level_support=3

参考资料:

http://fuzzytolerance.info/blog/apache-mod_fcgid-and-php-on-windows/

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">